Download

Download Thoys' Bot ( version 1.45 )



Requirements:

  • Windows XP Service Pack 2, Windows 2000, Windows Vista or Windows 7
  • .NET Framework 3.5 or higher
  • Internet Connection